What Web Browser should I use for the Qflow web dashboard?

We strongly recommend using the latest version of Microsoft Internet Explorer, Mozilla Firefox, Google Chrome or Safari. We suggest that you never use any version of a browser that is described as a Beta version. This means that it has not been fully tested and will almost certainly include software errors.

You may use other browsers. However, we cannot ensure that Qflow will be fully compatible.

Download the latest version of Google Chrome at   http://www.google.com/chrome

Please be aware Internet Explorer 7 is no longer supported.

Alternatively, get the latest version of the other supported browsers from their respective websites:

Mozilla Firefox –  http://www.mozilla.org/en-US/firefox/new/  

Safari –  http://support.apple.com/downloads#safari     

For further information or assistance please contact our Customer Support Team.

Feedback and Knowledge Base